University of Warwick system status

Exam timetable errors

Incident Report for University of Warwick

Resolved

Traffic is back to normal levels and the site is operating normally.
Posted Apr 21, 2026 - 17:18 BST

Monitoring

Traffic to exams.warwick.ac.uk has quietened down, timetables should generally be downloadable now
Posted Apr 21, 2026 - 14:38 BST

Investigating

We are currently investigating the issue with downloading timetables from exams.warwick.ac.uk.
Posted Apr 21, 2026 - 11:02 BST
This incident affected: Tabula (Exam timetables).