University of Warwick system status

Welcome Week is very busy at the moment

Incident Report for University of Warwick

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 13:26 BST

Investigating

Apologies we're currently experiencing heavy traffic, please try again later
Posted Sep 04, 2025 - 15:47 BST
This incident affected: My Warwick (Welcome Week).